Intermittent site errors
Incident Report for Exposure
Resolved
This incident has been resolved.
Posted 23 days ago. Nov 25, 2018 - 19:16 EST
Investigating
We are investigating reports of intermittent site errors. We are working to resolve this ASAP.
Posted 23 days ago. Nov 25, 2018 - 19:00 EST
This incident affected: Exposure Member Sites and Posts Platform, Member Statistics, and Member Dashboard.