Network Outage
Incident Report for Exposure
Resolved
All systems go! Sorry for the trouble.
Posted 15 days ago. Oct 29, 2018 - 17:32 EDT
Investigating
We are experiencing a network outage that are investigating and hoping to resolve asap. Please email support@exposure.co with any questions.
Posted 15 days ago. Oct 29, 2018 - 17:09 EDT
This incident affected: Exposure Member Sites and Posts Platform, Story Email Notifications, Member Custom Domains, Member Statistics, and Member Dashboard.