DNS resolving issues in certain regions
Incident Report for Exposure
Resolved
Our DNS changes now seem full propagated, any issues please let us know at support@exposure.co. Sorry or the inconvenience.
Posted 6 months ago. Jun 12, 2018 - 19:45 EDT
Update
Unfortunately while most members and visitors have access to the site some are still having issues. This is still due to the same DNS situation of some regions having incorrect records.

We are doing all we can to move this along but DNS is being unexpectedly slow and we don't have direct control over the how records are propagated across the web.

In some cases this can fixed on a browser level so please try the following steps to move things along.
• Restart your internet connection (router)
• Clear your saved information about Exposure (cache etc)
• Restart your computer and browser.
• Try a different browser if your main one still has an issue.

Thanks for your patience and any questions please contact support@exposure.co.
Posted 6 months ago. Jun 12, 2018 - 08:26 EDT
Update
Few more regions have now propagated. We are still working on trying to get the rest pushed along. In some cases DNS can take over 24+ hours so we should see the full issue resolved shortly.
Posted 6 months ago. Jun 12, 2018 - 01:09 EDT
Update
In some cases clearing your local browser data and restarting your computer and or internet connection can resolve the issue.
Posted 6 months ago. Jun 11, 2018 - 22:22 EDT
Update
More regions are now propagated but some are still experiencing issues. More updates!
Posted 6 months ago. Jun 11, 2018 - 22:04 EDT
Monitoring
The Exposure DNS is having some issues resolving in certain regions. This is causing some members to see 301 or 502 responses when visiting the site. We have been working with our provider to clean this up as fast as we can. We are monitoring the situation as it improves. The platform is full operational.

Stand by for updates and any questions please let us know at support@exposure.co
Posted 6 months ago. Jun 11, 2018 - 18:51 EDT
This incident affected: Exposure DNS.