Elevated Errors for Embedding YouTube Videos
Incident Report for Exposure
Resolved
A fix has been implemented and we are monitoring the results.
Posted May 17, 2020 - 10:05 EDT
Identified
We have identified an issue with our embed provider that is preventing Youtube videos from being embedded with just the URL. This issue should be resolved quickly but in the meantime, you can also use the "Custom Code" tab of the Embed groups to paste a YouTube embed code manually.

Sorry for the inconvenience.
Posted May 15, 2020 - 10:34 EDT