502 Bad Gateway Error
Incident Report for Exposure
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 10, 2018 - 20:00 EDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Jun 10, 2018 - 19:34 EDT
This incident affected: Exposure Member Sites and Posts Platform.