DDOS Attack Ongoing
Incident Report for Exposure
Resolved
Bad actors have been identified and squelched. Engineers are continuing to monitor the situation. Good service has been restored.
Posted Jun 27, 2023 - 15:06 EDT
Investigating
Exposure is currently under a DDOS attack from unknown origin, requiring the team to use a web firewall to ensure good service for legitimate web traffic. Our engineering team is working to identify the source and remediate.

Apologies for the degraded service
Posted Jun 27, 2023 - 09:48 EDT
This incident affected: Exposure Member Sites and Posts Platform.