Issues with site availability

Incident Report for Exposure

Resolved

Thanks for your patience! We are up and running. If you have any questions please email support@exposure.co.
Posted May 10, 2025 - 16:22 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 10, 2025 - 15:12 EDT

Update

A fix is currently in progress.
Posted May 10, 2025 - 15:12 EDT

Identified

We are aware that some signed out users can't access their site right now. The root cause has been identified and we are working on the fix.
Posted May 10, 2025 - 14:40 EDT
This incident affected: Exposure Member Sites and Posts Platform.