E-mail notifications take a long time
Incident Report for Exposure
Resolved
Incident has been resolved.
Posted Jun 01, 2023 - 15:58 EDT
Monitoring
Fix has been implemented. Please allow 24 hours for all unsent e-mail notifications to send as our e-mail servers work through the backlog.

If, after 24 hours your stories still haven't been published to your subscriber list, please reach out to support@exposure.co for further assistance.
Posted Jun 01, 2023 - 08:03 EDT
Identified
A server failure has been delaying outbound e-mails from Exposure, notably story notifications. The team has identified the root cause and is looking to implement a fix shortly.
Posted May 31, 2023 - 10:26 EDT
This incident affected: Story Email Notifications.