Dashboard interruption
Incident Report for Exposure
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 10, 2018 - 08:02 EDT
Investigating
We have had reports of intermittent interruptions to Member Dashboard access, we are investigating.
Posted 6 months ago. Jun 10, 2018 - 07:02 EDT
This incident affected: Member Dashboard.