Billing page outage
Incident Report for Exposure
Resolved
Service restored.

Please reach out to hello@exposure.co if you need any account issues sorted as a result of our billing system's outage.
Posted Jan 16, 2024 - 09:47 EST
Identified
An issue has been identified on our billing/subscription page. For any account adjustments / signups, please reach out to hello@exposure.co and we'll get you sorted in the next day.
Posted Jan 16, 2024 - 08:54 EST
This incident affected: Billing webhooks.