Site overloaded
Incident Report for Exposure
Resolved
Incident has been resolved. Additional resiliency work continues.
Posted Jun 08, 2023 - 13:22 EDT
Monitoring
We've identified the main culprits and have cut off access. Good service should be restored.

The engineering team is currently monitoring the situation and adding additional controls to avoid this particular type of service interruption in the future.
Posted Jun 08, 2023 - 10:52 EDT
Identified
Exposure is currently experiencing a DDOS attack. We are in-process of identifying the offending sources of bogus traffic and terminating them, with prejudice. Appreciate your patience.
Posted Jun 08, 2023 - 10:13 EDT
Investigating
We're currently experiencing a higher number of users currently trying to access Exposure. Our engineers are working to restore good service.
Posted Jun 08, 2023 - 08:50 EDT
This incident affected: Exposure Member Sites and Posts Platform.