Payment card form broken
Incident Report for Exposure
Resolved
Resolved.
Posted Mar 06, 2023 - 14:56 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 06, 2023 - 14:51 EST
Investigating
Our payment card form is broken, making creating a billing account and updating a credit card non-functional.

If you are attempting to add or update a card, please reach out to hello@exposure.co and we will get you sorted while our engineering team works on a fix with our vendor.
Posted Mar 06, 2023 - 14:45 EST
This incident affected: Billing API and Billing webhooks.